Subversive error because a newer version is already installed

Subversive error because a newer version is already installed

After a recent update to my Eclipse install every time I restarted the applicationI kept getting the following screen pop up
Subversive Connector Discovery

The issue was that it didn't matter which connector I installed I got a message stating
Cannot complete the request. See the error log for details.
"Native JavaHL XXX.XXX Implementation (Optional)" will be ignored because a newer version is already installed.
"Subversive SVN Connectors" will be ignored because a newer version is already installed.

After Google not helping me I went through the About Eclipse > Installation Details and removed all references to the connectors. In thescreen shot below you can see the last couple of references highlighted
Eclipse Installation Details: Subversive Connectors

With all of them removed I restarted Eclipse and was again presented with the Subversive Connector Discovery screen but this time the selected connectors installed fine.


comments powered by Disqus